Download Mono 2.8 parallel environment package for Ubuntu.


Update: Mono 2.10.1 64BIT debian package available on sourceforge! - http://sourceforge.net/projects/mono-parallel/files/mono-2.10.1-parallel-environment.deb/download

News:  An updated 2.8.2 64BIT debian package is now available on sourceforge. - http://sourceforge.net/projects/mono-parallel/files/mono-2.8.2-parallel-environment-amd64.deb/download


Last week the mono team  released the new 2.8 version with lots of  cool new features and improvements. I have created a new 2.8-parallel environment package and just uploaded it to Sourceforge, so you can use the new version for development/testing without manually compiling the whole stack  and compromising your system.

The parallel environment includes the following dependencies:

  • Mono 2.8
  • libgdiplus 2.8
  • xsp-2.8
  • mod_mono 2..8
  • mono-tools 2.8
  • gecko-sharp 2.0-0.13
  • gtk-sharp 2.12.10
  • gnome-sharp 2.24.1
  • gnome-desktop-sharp 2.24.0
  • mono-addins 0.5

Once downloaded, the package installs to "/opt/mono-2.8". So it lives side by side to the previous 2.6 package i recently published.
I do not have an automatic build script yet, so it's manually assembled . If more people are interested in this package I'll probably publish it on my launchpads ppa, so that's easier to grab new versions.

For now everything is stored on Sourceforge, so just Download it here.

Once installed, you can activate the environment by typing the following command in your terminal:

droth@ubuntu04:/var/dev/mono$ source mono-2.8-environment

Toward this step your terminal looks like this:
[mono] /var/dev/mono @

If you now enter "mono -version" the console should print the following lines:

Mono JIT compiler version 2.8 (tarball Thu Oct  7 17:21:25 CEST 2010)
Copyright (C) 2002-2010 Novell, Inc and Contributors. www.mono-project.com
TLS:           __thread
SIGSEGV:       altstack
Notifications: epoll
Architecture:  x86
Disabled:      none
Misc:          debugger softdebug
LLVM:          supported, not enabled.
GC:            Included Boehm (with typed GC and Parallel Mark)

If you want to use the new Generational GC, use the following command:

"mono-sgen --version"

Mono JIT compiler version 2.8 (tarball Thu Oct  7 17:21:25 CEST 2010)
Copyright (C) 2002-2010 Novell, Inc and Contributors. www.mono-project.com
TLS:           __thread
SIGSEGV:       altstack
Notifications: epoll
Architecture:  x86
Disabled:      none
Misc:          softdebug
LLVM:          supported, not enabled.
GC:            sgen

Happy .NET/Mono hacking!


comments powered by Disqus